T3d-export-import of page tree does not work

We have an TYPO3 v11 installation which uses in2publish. So there is an system for editors and with a workflow content (records and files) are published to the live system.
Both systems have the same configuration regarding extensions.

Now a remodelling of a pagetree has gone wrong and I want to restore a pagetree from the live system to the editor system without restoring on record level as a lot of records (pages, CE) are edited and will be used in other context.
Therefore I tried to export the pagetree from the live system and import it into the editor system.

I export ‘all tables’ with relations to ‘all tables’

The export works without errors, alas there are no files exported. (this should not be necessary as all files should exist in the editor system (and also the sys_file* records).

on trying to import the t3d file the preview shows: ERROR: One of the inputs were not an array! on pages and most files.
The import ends with the error: `No file reference (sys_file_reference) was found for given UID: “1”’

The page(s) exist and content elements exist too. but only titles are stored of the CEs. Additional fields and images are empty.
The page tree root page fails to display in the FE ` 503 / # Oops, an error occurred! / You must either specify a string src or a File object.’
some pages can be shown, but only headers are shown.

I tried different configurations, but all gave the same result.
Independent of exporting only one page or the whole tree (~150pages)


Tab ‘Configuration’
Levels: This page / Infinite
Include tables: [ALL tables]
Include relations to tables: [ALL tables]
Use static relations for tables: [ALL tables] / only sys_file*
Show static relations
Exclude disabled elements


Tab File & Preset:
:
File Format: XML / T3D file / T3D file compressed
:


Tab Advanced Options:
:
Files: / Save files in extra folder beside the export file (supported for “Save to filename” only)
Select extensions that the exported content depends on:
(all selected)


for the import I selected no option to get new records and keep the edits made to the old records.

Any ideas what is missing?

Hi Bernd!

You’re not saying if the page tree remodeling went wrong because of manual or technical error, but I would say it sounds like some inconsistency in the database.

Maybe there is actually an error on the export side that isn’t detected until you try to import the data back in?

— Mathias

I have to correct me:
I did inspect the export and I’m surprised about the data structure.

At first sight I thought it missed a lot of data (therefore my first version of this answer), but the data is in the file. the structure includes a relation part, where records are represented only minimal (just header, partially shortened).
Only looking farther I found that each record has a data representation, where all fields are stored.

So the export seems to include all information, but the import does not reads all data or does not assigns all data correctly.

1 Like