Js is not Loading on frontend

Hello Everyone,

I’m new in typo3 and I have updated typo3 version from 8.7.32 to 12.4.9 then after some js is not loading and it’s showing 403. Please see the attached screenshot and Please help me.Thank you.

Hi Rohit!

In TYPO3 v12 the CMS no longer links directly to assets in the extension folder. They are instead placed in public/_assets. Check out the documentation for the new _asset folder, as well as the links in the See also box.

Best wishes


1 Like

Hello Mathias,

Thank you for quick response. We have updated typo3 version using symlink so we don’t have public folder. So in this case how can put assets on other folder. Could you please guide me?


I haven’t used TYPO3 without Composer for many years, so I’m not sure how to solve your problem. I’ll check if I find someone who know more about it.

PS! I can highly recommend migrating your installation to Composer.

I’m not familiar with none composer setups. Your URLs include the Private folder which indicates this should not be accessible by the web server. Public resources are expected within the Public instead of Private folder.

403 also indicates files are there, but access is restricted. I guess TYPO3 delivers an .htaccess file with corresponding rule.

I’d suggest move the public files to Public folder and adjust paths and give it a try.


Hello Daniel,
Good Morning!

Thanks for help ! We will try on that way.

Hello Daniel,

Your suggestion is worked, thank so much you for help.

1 Like

Hello Daniel,

We have move js files in public folder then after error is not showing but js is not worked and no any error on console so can you please help me. I’m new in typo3.