Flux not working in Typo3 v12.4.14


I’m trying to update an old Typo3 Installation from v9.5.x to v12.4.14 for over a week now and I’m getting desperate.

I’m not using Typo3 very much, but I made it work in v9.5 a few years ago all by myself. But in the new version 12.4.14, I just don’t get a basic setup with the flux extension working. Maybe something important changed?

I tried many different approaches and read the documentation for fluid and flux.
I installed many clean Typo3 installs for testing purposes locally.

  • via Composer
  • via manual installation (the old way)
  • I tried importing the old sitepackage
  • I also tried clean installs with new generated sitepackackes from https://www.sitepackagebuilder.com (with the fluid styled content setting, of course)
  • The database is also fresh for my test installs, of course.

I installed the following Extensions:

  • Flux 10.0.10
  • VHS 7.0.3

It seems Fluidpages is deprecated and/or not maintained any more. So I didn’t install this in the new clean install.

I added the Typoscript record and included both the fluid_styled_content and my sitepackages TypoScript sets. I removed the 4 lines of generated TypoScript under Setup.

I encounter the first big problems in the Page-properties of the root page I created: When I select “Columns from selected “Page Layout”“ under Appearance (as in the flux documentation), I don’t see the Button to add content elements in the page. Only if I create a backend-layout and select it here, I can add content elements at all.

Ihn the frontend I get the error

Please select a page template in page properties. Oops, an error occurred! Code: 202405080622166d82eaa8

But the dropdown under Page Layout in the page properties is empty!

The error log says Typo3 is looking in the right template directory, but depending on my selection under appearance, it expects a template named Default.html, 1.html or Flux.html. If I manually rename the template, at least this template is used. But it still states:

Please select a page template in page properties.

at the top.

Much worse is, I don’t get any content elements to show up in the „create new content element“ modal window. I tried the default-paths in my Sitepackage, flushed all cashes, but nothing. I tried very minimal Flux-templates to eliminate errors. But they don’t even show up.

In the old Typo3 v.9.5 I only had to add the template-file to the EXT:provider/Resources/Private/Templates/*-folder and they showed up.

I don’t think flux is not working any more. It’s much more likely I forgot something small somewhere when setting up my clean install.

Please tell me if you need anything more. I’d really appreciate any help – I’m starting to get desperate.

Kind regards

Hi Markus!

Welcome to talk.typo3.org!

Maybe @namelesscoder is the best person to answer this question?

I am no expert on Flux, but googling a bit, I can see a number of posts about “Please select a page template in page properties.” in relation to the Flux extension. Maybe one of these could be of help?

Hope that helps! Let me know how it works.

— Mathias

Some things to check:

  • If you’re viewing a sub page, make sure that the parent or root page has a page layout selected for “Page Layout - Sub Pages”.
  • If - and only if - your page template contains a flux:grid definition and you want to use this, then make sure that the parent or root page has the special “Columns from selected page layout” selected in “Appearance”. If your page template doesn’t have a flux:grid you’ll have to create a backend layout in the standard way and use that.
  • If you copied the templates from the older version, try creating a fresh page template with an absolutely minimal setup. Flux 10 (and VHS 7) is a new major version indicating there are breaking changes and some of those breaking changes relate to ViewHelper arguments that could prevent the template from being parsed correctly by Fluid.

I removed the 4 lines of generated TypoScript under Setup.

This might be a mistake if you want to rely on the automatic registration of TS to render page templates (if you only have Flux on your system I’d recommend that approach). Removing the TS should only be done if for some reason you have to manually register a PAGE TypoScript object and in this case you have to reproduce the TS that Flux would normally add, if you still want to use Flux to render your page template.

But the dropdown under Page Layout in the page properties is empty!

Normally this indicates that the template is somehow not able to be parsed by Fluid which usually means an invalid ViewHelper or ViewHelper argument has been used. However: if this selector box fills with values after multiple refreshes you’re experiencing a bug caused by instance reuse of TYPO3v12; this bug is fixed in the 10.0.10 version of Flux that was released a short while ago.

If you need a reference for how to create and register a provider package, see and install GitHub - FluidTYPO3/test_provider_extension: Testing/demonstration FluidTYPO3 provider extension which always shows the current practice compatible with the most recent Flux version.

And if all else fails I’d suggest coming to TYPO3’s slack in channel #flux, it’s a bit easier and more appropriate to support you there.