Error when installing extensions

I came across this error when trying to install extensions and I would like to share it with the community to see if we can find a resolution. This is what I have done:

Problem 1

  • Root composer.json requires typo3/testing-framework dev-main → satisfiable by typo3/testing-framework[dev-main].
  • typo3/testing-framework dev-main requires typo3/cms-backend 13..@dev → found typo3/cms-backend[v13.0.0, …, v13.2.1] but these were not loaded, likely because it conflicts with another requirement.

You can also try re-running composer require with an explicit version constraint, for instance, composer require bk2k/bootstrap-package:* to see if any version is installable, or composer require bk2k/bootstrap-package:^2.1 if you know which version you need.

Installation failed, reverting ./composer.json to its original content.

The error message indicates a conflict in version requirements between the typo3/testing-framework and typo3/cms-backend packages in your composer.json file.

To resolve this, I have tried multiple approaches, including but not limited to:

  1. Removing the current lock file and attempting to update both dependencies:

composer update typo3/cms-backend typo3/testing-framework

  1. Using the flag --with-all-dependencies to solve dependency-related issues:

composer update --with-all-dependencies

However, the issue persists as there is a conflict between the typo3/testing-framework package, which requires typo3/cms-backend 13.*@dev, and the actual versions of typo3/cms-backend found in the installation.

The persistent conflict between typo3/testing-framework and typo3/cms-backend suggests an underlying compatibility issue between these modules and another module already installed in your system.

I am new to TYPO3 but I am willing to learn because I believe in the platform from what I’ve read about. Any help will be appreciated!