#1681549038 LogicException at Typo3-CMS/Form first use

Hey everyone,

I am quite new at Typo3 and just installed myself a Typo3 13.1.1 on my webserver. I didn’t installed it with composer or ddev, I just copied the files onto the webserver and run the install script via browser.

After I setted up my Sitepackage and designed a custom layout I wanted to use the Typo3 Core Form extension but when I go on the “Forms” page in the backend i get the following error message:

(1/1) #1681549038 LogicException

Configuration could not be loaded

/httpdocs/typo3_src-13.1.1/typo3/sysext/form/Classes/Controller/AbstractBackendController.php line 48

I tried to figure out what config is missing and if I could insert it by myself, but i wasn’t successfull.
I already moved the sysext folder “forms” and tried to install the extension from the github repo, but it seems that the repo is for 13.1.2 and I don’t want to upgrade everything (and don’t know how right now).

Do you have any hints where I should look for problems, or what I can do to fix the issue?

I am looking forward for help!

Thank you!

The config should be available. You could first try to deactivate and then activate the form extension in the extension-manager. Maybe that helps.

The configuration that should be loaded is in the file:
EXT:form/Configuration/Yaml/FormSetup.yaml (line 146 ff)

Here is the FormSetup.yaml for TYPO3 13.1.1:

You could check if the file maybe is broken on your server. Maybe it’s not uploaded properly.

If that all not helps, i would consider to install TYPO3 via composer.

Hey Mogens,

thank you for the answer!
I already tried to deactivate and activate the extension. It didn’t helped.
I checked the FormSetup.yaml and it looked the same. I also tried to replace the content witht the github file but no difference.

Can there be a bug with installing the extension or to initialize it?
What script is called when activating the extension?

I have problems with composer and trying not to reinstall with composer, but will do otherwise.

Thank you for the help!

I don’t think there is a bug while installing/initializing the extension. The extension-manager is a backend-module calling following method, whenn installing an extension:

But at least there is not happning to much there. In legacy mode the extension is added to the Array in typo3conf/PackageStates.php.

How do you upload the files to your server?

Thank you!
I ‘wget’ the tar.gz from the website and decompressed it.
So I did this via ssh and other files like my sitepackage were uploaded via sftp.
I tried to trace down the function calls but couldn’t find the code where the yaml config is loaded.
Do you have the position ready? If not i will do some more research.

I don’t just want to say ‘there is an error, i reinstall it’ – I would like to know where the error happend.

Am I right that the config is loaded here into TypeScript Setup?

EXT:form/ext_localconf.php (line 20 ff)

    // Add module configuration
        'module.tx_form {
    settings {
        yamlConfigurations {
            10 = EXT:form/Configuration/Yaml/FormSetup.yaml

Can I put these lines into my TypeScript Config by hand?

I did some testing and I found out that

$typoscriptSettings = $this->getTypoScriptSettings($extensionName);

in EXT:form/Classes/Mvc/Configuration/ConfigurationManager.php (line 98) returns an empty array.
Therefor I investigated what getTypoScriptSettings() does and concluded it loads the settings in

protected function getPluginConfiguration(string $extensionName, ?string $pluginName = null): array

in EXT:extbase/Classes/Configuration/BackendConfigurationManager.php (line 278).
I var_dumped() the $setup array and couldn’t find any [module.] key in it.
Could it be there for?

When I manually fill the $setup array with the following values:

if( $extensionName === "form") {
	    $pluginConfiguration = [
		'settings' => [
		    'yamlConfigurations' => [
			10 => 'EXT:form/Configuration/Yaml/FormSetup.yaml'

I get rid of the error exception and seemingly can use the extension.

I don’t get what’s going wrong there.

Sorry. I don’t know what’s going on there.
Maybe someone else has any idea.